Can I stay on Ektron CMS?

Ektron CMS is still supported, but Episerver recommends that customers should be on at least version 9.0 or greater of Ektron CMS or the Digital Experience Cloud.